Back to overview
Degraded

Degraded API performance; elevated 429 rate limit errors

Apr 27, 2026 at 3:35pm UTC
Affected services
API

Resolved
Apr 28, 2026 at 3:42pm UTC

The deployed fix has proven effective, and API performance has returned to normal levels since this night. We have re-enabled credit charging for API calls, as the 429 rate limit errors are no longer occurring at elevated rates.

Thank you for your patience throughout this incident. If you continue to experience any issues, please reach out to our support team.

Updated
Apr 27, 2026 at 7:46pm UTC

We have deployed a fix addressing the elevated 429 rate limit errors and are currently monitoring the results. API performance should be returning to normal. We'll continue to observe the system and will post a final update once we've confirmed full resolution.

Credit charges for 429-failed requests remain disabled until we mark this incident as resolved.

Updated
Apr 27, 2026 at 4:01pm UTC

As mitigation while we work on a fix, we have temporarily disabled credit charges for any API calls that fail with a 429 rate limit error during this incident.

Existing API calls that succeed will continue to be charged as normal.

Created
Apr 27, 2026 at 3:35pm UTC

We're currently experiencing degraded performance across our API. A subset of requests is failing with HTTP 429 (rate limit) responses, and integrations may see intermittent failures or need to retry affected calls.

Our engineering team is investigating the root cause and working on a fix. We expect a full resolution to be in place within the next 72 hours and will post updates here as the situation evolves.